Scheduling Infrastructure Upgrade

Scheduled for Apr 12, 09:00 - 10:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 30, 2026 - 17:21 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 26, 2026 - 08:42 UTC

Scheduled

On Sunday, April 12, at 9:00AM (UTC), we will conduct scheduled maintenance. During this period, we will carry out necessary maintenance on our infrastructure. No service interruption is expected.
Posted Mar 26, 2026 - 08:42 UTC
This scheduled maintenance affects: Optimization (Vehicles Optimizations, Duties Optimizations, Optimization & Generation) and Scheduling (Manual Edit, Projection, Preferences).