Activity Page not showing vehicle positions for past days

Incident Report for Optibus Platform

Resolved

Data is accessible again in the Activity Page.
Posted Sep 05, 2025 - 19:18 UTC

Update

We are recovering the data. All our clients will start seeing vehicle positions for past days in the following hours.
Posted Sep 04, 2025 - 18:56 UTC

Identified

We are currently experiencing issues displaying historical vehicle positions on the Activity Page.
Our team is aware of the problem and is actively working on a solution.
We apologise for the inconvenience and will keep you updated as we make progress.
Thank you for your patience and understanding.
Posted Sep 04, 2025 - 13:03 UTC
This incident affected: Control (Web App).