Operations - AWS issue affecting North American and LATAM customers / Driver App - AWS issue affecting users in all regions

Incident Report for Optibus Platform

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 10:15 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 09:45 UTC

Monitoring

AWS is indicating they see things starting to recover, and Operations products appear to be resolved.

We are monitoring it to verify that all issues are resolved on our platform.
Posted Oct 20, 2025 - 09:41 UTC

Update

We’ve identified that the ongoing AWS issue is affecting access to the Driver App for users in all regions. We’ll continue to keep you updated here.
Posted Oct 20, 2025 - 09:05 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 08:29 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 08:28 UTC

Identified

We’ve identified an AWS issue affecting the platform in North America and LATAM and are working to resolve it. We’ll keep you updated here.
Posted Oct 20, 2025 - 08:26 UTC
This incident affected: Operations (Platform, External REST API) and Control (Web App).